Synology Force you to install all older version of PHP 5.6 and PHP 7.0 – Apache 2.2 and 2.4

Synology Force you to install all older version of PHP 5.6 and PHP 7.0 – Apache 2.2 and 2.4

This is really a weird thing which synology needs to solve in its future DSM updates. If I use PHP 7.2, why am I forced to install version 5.6 and version 7.0? Why am I forced to install the APACHE 2.2 version if I only use the APACHE 2.4 version? And why am I still forced to overload my Synology with non-use services but which are interconnected with each other?

synology php 5.6 and 7.0 and 7.2

I can not uninstall an older version of PHP or APACHE because if I do this, I’m forced to uninstall all the latest versions as well. I do not know who managed this package update process but it is badly managed.

If the old process is running, can I stop it? Of course not. If I want to do this, I have to uninstall all the latest version too. CRAZY!

Are there any official answers and some future updates to solve this “big” problem? At the moment no.

What do you think about this problem? I’m not interested in circumventing this by installing virtual machines or something like that. The package system needs to be reviewed and modernized because it’s done wrong. Readers, do you find yourselves facing the same problem too?

Later edit: I just found out why Synology is dependent on PHP 5.6. It’s not really Synology that depends on PHP 5.6, but 3rd-party applications like phpMyAdmin. Although I haven’t found out why it’s still dependent on Apache 2.2.

Last Updated on by Marius Bogdan Lixandru