Synology: Force you to install all older version of PHP 5.6 and PHP 7.0 – Apache 2.2 and 2.4

Synology Force you to install all older version of PHP 5.6 and PHP 7.0 – Apache 2.2 and 2.4

This is really a weird thing which Synology needs to solve in its future DSM updates: dependencies. For example PHP 7.2 is dependent on earlier versions, and so is Apache 2.2. If I am using PHP 7.2, why am I forced to also install versions 5.6 and 7.0? Why am I forced to install APACHE 2.2 if I am only using APACHE 2.4? Why do I have to overload my Synology NAS with earlier versions of various packages and services which are of no real use just because they are made to be interconnected, relying on each other to function?

synology php 5.6 and 7.0 and 7.2

At this moment in time I’ve found that you cannot uninstall older versions of PHP and APACHE because, if you do this, you then have to uninstall the latest versions as well. So you basically can’t use the newer versions unless you also have the older versions installed too. I don’t know how this came to be, but it’s simply of no use to have newer versions of vital services reliant on one or multiple older versions.

You may be asking yourself: if an older version of a service is running, can I stop it? Of course not. If you want to do this, you also have to uninstall all the latest versions too. CRAZY!

Are there any official statements on the topic and maybe announcements of future updates meant to take care of this issue? At the moment no. What do you think about this problem?

I’m not interested in circumventing this issue by installing a virtual machine or something like that. The package system needs to be reviewed and modernized because it’s simply not done right. Readers, do you find yourselves facing the same problem too?

Update: 9.02.2019

I just found out why newer versions of PHP on Synology NAS devices are dependent on older versions such as PHP 7.2 requiring PHP 5.6 in order to work. It’s not actually Synology’s system that requires PHP 5.6, but 3rd-party applications like phpMyAdmin. I haven’t yet found out about Apache 2.2 dependencies.

Update: 8.07.2019

The WordPress application is still dependent on the old Apache 2.2 version, but Apache 2.2 being a requirement for WordPress is inexplicable as it is not just unsupported, but also superseded by version 2.4 which is also very much available for use and perfectly compatible. Apache 2.2 cannot be stopped if you have the WordPress app installed on your Synology NAS.

At the moment you have to uninstall the WordPress application from Synology and download and install the official WordPress from to solve this issue. If you do decide to use the official WordPress which will allow you to uninstall the Synology WordPress app, then you can also uninstall the old Apache 2.2 version creating a dependency.

This post was updated on Tuesday / August 10th, 2021 at 11:34 PM